Enhanced SteamGifts & SteamTrades (ESGST)

An extension / userscript that adds some cool features to SteamGifts and SteamTrades.

If you find any bugs or have any feature requests, please file an issue here.


Compatibility

Tested and confirmed as working:

  • Chrome (since v55)
  • Firefox (since v52)
  • Pale Moon

Not tested but should be working:

  • Any Chromium-based browser (such as Opera, Vivaldi, etc...)

Not supported:

  • Edge
  • Safari

Installation

There are two different ways to use ESGST: extension or userscript. You can choose which one you want to use, but the extension is a lot faster and has a better peformance than the userscript, so I recommend it, although there is no major difference between them, except for a few options that are only available in the extension because of limitations in the userscript.

Option 1 - Extension

It should be possible to install the extension in any Chromium-based browser from the Chrome store (such as Opera, Vivaldi, etc...), any Firefox-based browser from the Firefox store (such as Waterfox, etc...), and any browser that uses the Phoebus system from the Pale Moon store (such as Basilik, etc...).

You can also use the extension on Android through Firefox for Android, but some features might not work or not be optimized enough for mobile.

Option 2 - Userscript

To install the userscript, you must install Violentmonkey, Tampermonkey, Greasemonkey or some other userscript manager first. Then click here and you should be prompted to install it. I recommend Violentmonkey or Tampermonkey, because the userscript uses the GM_addValueChangeListener API to communicate changes in the storage between tabs, and that API is not available on Greasemonkey, so a polyfill is used for Greasemonkey, which is not very effective and can affect the performance.

You can also use the userscript on Android through Firefox with Violentmonkey or USI, but some features might not work or not be optimized enough for mobile.


Beta Versions

The latest beta version for both the extension and the userscript is always available in the latest pre-release in the releases page.

5 years ago*

Comment has been collapsed.

Is there a known issue with ESGST failing to read Steam game ratings in Firefox?
I recently switched from Chrome to Firefox for better performance but noticed that a lot of games are missing Steam ratings compared to Chrome.

Anyone know what might be causing this and if there's a way to fix it?

Update: Clearing the browser's cache fixed the issue.

Top Image = Chrome
Bottom Image = Firefox

View attached image.
View attached image.
4 months ago*
Permalink

Comment has been collapsed.

i reinstalled the script and now i can't filer entered giveaways
on filters pages it shows 0 entered

Edit: i downgraded and works fine

4 months ago*
Permalink

Comment has been collapsed.

Hello, script shows only the recent reviews numbers, and not all.
I cannot seem to find the correct setting. Can you please help?

3 months ago
Permalink

Comment has been collapsed.

It's a know issue. A github ticket was submitted for it 7 months ago:
https://github.com/rafaelgomesxyz/esgst/issues/1732

It's not clear if the developer is actively working on ESGST right now. The last update was on 07/2021. So, we'll have to be patient.

3 months ago
Permalink

Comment has been collapsed.

Thank you for information!
He can take all the time in the world, his script is a treasure

3 months ago
Permalink

Comment has been collapsed.

I just found out about this script and installed it, great job!
One thing that I cannot find out: How to save filter settings so that they are used for every new page?
For example I only want to see games with 11 points or more. How can I apply that permanently?

3 months ago
Permalink

Comment has been collapsed.

Save as a preset, its located on the right side of the filters ;)

3 months ago
Permalink

Comment has been collapsed.

Thanks but I cannot find that option

View attached image.
3 months ago
Permalink

Comment has been collapsed.

That's advanced search use giveaway filters for what you want.

3 months ago
Permalink

Comment has been collapsed.

I have it activated but I cannot find it at or anywhere else.

View attached image.
3 months ago
Permalink

Comment has been collapsed.

I'm not sure what page you're looking at there.

There should be a bar on the main steamgifts page just above the giveaways that says "Expand filters".
Clicking on that opens up a panel where you can define your filter and save it as a preset.

You can switch between presets by clicking on the icon that I highlighted in yellow.

View attached image.
3 months ago
Permalink

Comment has been collapsed.

Are you on SG Dark Grey version 2.3.3 ? it looks outdated or something else is interfering with it.

3 months ago
Permalink

Comment has been collapsed.

It's a weird mix of "Dark Grey 2.3.3" and "Compact + ESGST Styling" on top of each other plus some other random tweaks. Works for me.

3 months ago
Permalink

Comment has been collapsed.

For comparison

View attached image.
3 months ago
Permalink

Comment has been collapsed.

Yeah, I see it. Nice work on developing these styles btw!

3 months ago
Permalink

Comment has been collapsed.

Thanks a lot, I was too blind for that.

3 months ago
Permalink

Comment has been collapsed.

How do I filter GA listings by game genre or Steam tag?

Suppose I want to filter out the genre: Racing
or the Steam tag: Indie

I think ESGST is already made to do this, but I can't figure out how to do it.

3 months ago
Permalink

Comment has been collapsed.

You need to enable

9.2.12 (Games->Game Categories->Genres)
9.2.12.2 (Games->Game Categories->User-Defined Tags)
3.21.2.70 (Giveaways->Giveaway Filters->Multiple Filters->Genres)

Make sure that 9.2.12.1 is disabled

Then you can enter a comma-separated list of genres/tags to filter by. It will filter for GAs that have any of those tags.

If you want to filter for combinations of tags, you have to create separate Genres rules.

View attached image.
View attached image.
3 months ago
Permalink

Comment has been collapsed.

Thank you for responding. I appreciate your time.
I've made those settings changes, but...
I don't know how to get to those screensnips you posted. What do I click to see that?
This is what I get when I click Manage Game Tags:

View attached image.
3 months ago
Permalink

Comment has been collapsed.

I think the popup in your screen clip is for managing Game Tags, not Steam Tags. Game Tags are custom labels that you define and attach to games. They're enabled by 9.4 Games->Games Tags. That's not what you want.

To get the Genres/Steam Tags filter box, you need to expand the filtering panel that's added by 3.21.2 Giveaways->Giveaway Filters->Multiple Filters

Adds a collapsible panel below the same main page heading that allows you to change/save the rules of a preset.

There should be a bar above the list of giveaways that tells you how many games are getting filtered. If you click on it, it expands and lets your define filtering rules.

View attached image.
3 months ago
Permalink

Comment has been collapsed.

That's it! Thanks, you did a great job.

Mine still looks different...

But now it does the filter I wanted. Thanks again.

View attached image.
3 months ago
Permalink

Comment has been collapsed.

Cool. Glad that it worked for you!

My guess is that yours looks different because you have 3.21.2.3 Hide Advanced Filters enabled. You don't need to disable it unless you plan to do some complex AND/OR conditions.

3 months ago
Permalink

Comment has been collapsed.

esgst randomly stopped working after a page refresh..
I already tried restarting the browser (chrome 99.0.4844.84) and rebooting the pc; is there a way to backup data (had quite a bunch of bookmarked gas..) before trying to reinstall it?

3 months ago
Permalink

Comment has been collapsed.

top row above search bar, third button from the left (up arrow), second from left (down arrow) loads a backup

3 months ago
Permalink

Comment has been collapsed.

problem was that I didn't have a backup, so I was wondering if I could recover data while esgst was still installed but not working..

well, nevermind, I just reinstalled and resynced everything.. now I just have to remember to backup once in a while xD

3 months ago
Permalink

Comment has been collapsed.

preferably just before you can't πŸ€žπŸ˜†

3 months ago
Permalink

Comment has been collapsed.

How can I delete templates?

I made a few templates for creating giveaways. But I don't know how to detele them. There is a button for deletion (a simple recycle bin), but when I press it, it starts trying to delete it, however an hour have passed, and it's still trying to delete it.

3 months ago
Permalink

Comment has been collapsed.

Deleted

This comment was deleted 3 months ago.

3 months ago
Permalink

Comment has been collapsed.

may simply need to reopen browser
as a workaround, can edit the templates file, in the compressedfile in AppData, in Firefox it's an xpifile (renamed zip)

3 months ago*
Permalink

Comment has been collapsed.

Thanks for the answer.

Where is the compressedfile in AppData?

3 months ago
Permalink

Comment has been collapsed.

if you don't know that, then you're not skilled enough to even attempt such a thing, seriously

3 months ago
Permalink

Comment has been collapsed.

Not sure if this is still a problem for you but I ran into the same issue today and figured I'd share what I did.

I ended up deleting the unwanted templates by backing up the templates data in ESGST, modifying the json file manually and then restoring the templates from that file.

2 months ago
Permalink

Comment has been collapsed.

Thanks for the help. Sounds a little too complicated for me, still. I don't know how to modify the json file manually.

Let me put you in my WL as thanks, at least

2 months ago
Permalink

Comment has been collapsed.

Thanks!

It's not that complicated really. Give it a go if you're feeling adventurous!

  1. In ESGST, click on the backup icon. Make sure that only Templates is selected, then choose "Text" as the backup option.

  2. Copy the text that pops up into https://www.jsonlint.com and click on Validate JSON to format it.

  3. Now you can edit the JSON.

    Each template is enclosed in a set of curly braces "{ }" and templates are separated by commas. You can modify, add, delete templates as you wish. It should be pretty self explanatory. To delete a template, just remove everything inside and including its curly braces plus an adjacent comma.

  4. When done, click on Validate JSON again to check for syntax errors.

  5. In ESGST, click on the restore icon. Again, make sure that only Templates is selected, then choose "Text" as the restore option.

  6. Paste the modified JSON into the new popup window and click Restore. Voila!

2 months ago
Permalink

Comment has been collapsed.

Aaaand, it worked perfectly. Thank you!

The instructions were extremely easy to follow. Seriosly, thanks for all the trouble. Hopefully more people will see this to learn how to do it.

I would put you 100 times in my WL. Thank you again for all the help.

2 months ago
Permalink

Comment has been collapsed.

Opening the Giveaways Created page (https://www.steamgifts.com/giveaways/created) slows/freezes the browser for a minute and has a huge memory spike. The winners column is blank except for the latest one.

3 months ago
Permalink

Comment has been collapsed.

Do you have setting 3.5.1 enabled (Created/Entered/Won Giveaway Details)? That setting sends a lot of requests to SG which tends to cause performance issues, in my experience. I had to disable Endless Scrolling on the Giveaways->Created page to deal with the problem.

3 months ago
Permalink

Comment has been collapsed.

Yes I had it enabled. Disabling it does fix the problem. It used to work fine before though. I don't have endless scrolling enabled anywhere.

I'll have to leave it disabled until it can get fixed. Thx for the tip! What the hell I'll give you a WL for helping :)

3 months ago*
Permalink

Comment has been collapsed.

I see dead people good things coming in your future
congrats! you just qualified as an πŸ‘‡πŸΆ, by the skin of your teeth, welcome to the secret kennel! πŸ’™

View attached image.
3 months ago
Permalink

Comment has been collapsed.

Can we use ESGST to filter out games by keywords in the title of the game? I have filters against Genre for 'Adult', but some of those games don't have the 'Adult' tag -- even when 'Adult' is in the title. That's why I'd like to filter by title.

Is ESGST already set up to do this? I've looked in the settings, but I don't see it.

2 months ago
Permalink

Comment has been collapsed.

After the last sync, green and red colors for WL and BL are gone in the forums. That's strange. Any idea what to do?

2 months ago
Permalink

Comment has been collapsed.

Is highlighting broken only in the forums? That's very strange...

If highlighting doesn't work everywhere, then maybe your ESGST data got corrupted or lost somehow. My only suggestions would be to resync your WL and BL, but ESGST warns you that it's a very time consuming process (1 request/sec). Maybe try restoring those lists from a previous backup if you have one and then resync.

2 months ago
Permalink

Comment has been collapsed.

Yup, broken only in the forums. I will resync WL and BL after the resync for that is available again. Thank you for your answer

2 months ago
Permalink

Comment has been collapsed.

Yeah, well... A manual resync didn't help. Restoring data from old backup didn't help. I am still missing green and red colours for WL and BL respectively. And it's not only in the forums, it's everywhere on SG. Only people I added in the last three weeks have colour.
Any ideas, anyone?

1 month ago
Permalink

Comment has been collapsed.

Rafael over optimized the sync which backfired by dropping old data. If you have an old backup you can merge it to have all combined.

Users - Main
Users - Whitelist/Blacklist Checker

1 month ago
Permalink

Comment has been collapsed.

Thank you for trying to help me, but it didn't work

1 month ago
Permalink

Comment has been collapsed.

I just had the issue myself and that solved it for me.
Did you use the merge option? and does the old backup actually have the old data?

1 month ago
Permalink

Comment has been collapsed.

Yes to both

1 month ago
Permalink

Comment has been collapsed.

If you load the old backup in full, does it show up then?

1 month ago
Permalink

Comment has been collapsed.

Already tried that a few weeks ago, colours were gone even with the old backup that included the correct information. To be honest, I'll deal with it. Would it be nice to have the colours back? Sure. But it's not the end of the world if I can't get it to work again.
Thank you! :)

Edit: Took one of the older backups, nearly six months ago, and tried merging again. This worked. So thank you again! :)

1 month ago*
Permalink

Comment has been collapsed.

included the correct information

how do you know that when it doesn't work?

try an older backup?

Just to make it clear, is it about the Blue Heart symbol for who you whiteisted, or the green check mark for who whitelisted you, or both?

(ninja edit sniped xD)

1 month ago*
Permalink

Comment has been collapsed.

Syncing your Steam groups...

How long should that take for 202 groups?
I've waited for ~10 mins and nothing... White/blacklist syncs just fine and I've tried allowing all the sites ESGST asks for and even cleared my browser data.

View attached image.
2 months ago
Permalink

Comment has been collapsed.

I can confirm that I'm experiencing the same thing even with 83 groups. I tried from 2 different PCs.

My last ESGST groups sync is 7 days old even though I have it set to sync automatically every day.

2 months ago
Permalink

Comment has been collapsed.

The first setting was enabled, tried with them both enabled and left it to run for 20 mins... Still no dice.

View attached image.
2 months ago
Permalink

Comment has been collapsed.

:(

2 months ago
Permalink

Comment has been collapsed.

I remember when I first synced my groups I had to do it in small batches. Hit "sync", let it run for about 30 seconds, hit the stop button. It should list a few dozen groups that it successfully synced. Repeat until finished.

It was a pain, but it did the job.

2 months ago
Permalink

Comment has been collapsed.

I get the following error in Console when syncing Groups:
TypeError: s.getElementsByClassName(...)[0].style.backgroundImage.match(...) is null esgst.js:32:52852

If I backup ESGST's Groups data to a json file after running the sync for a few minutes, I see no progress at all, so it appears that the above error is blocking.

I think the problem has to do with the way certain groups' avatar images are stored on Steam or how SG is linking to them.
If you check the URL of a group's avatar image on its SG page, it'll be one of these two formats:

  • https://cdn.akamai.steamstatic.com/steamcommunity/public/images/avatars/<xx>/<ImageID>_full.jpg
    (<xx> = first 2 characters of <ImageID>)

  • https://avatars.cloudflare.steamstatic.com/<ImageID>_full.jpg

I found that groups that use the second format are problematic. They break ESGST's 'Content Loader->Groups' and 'Stickied Giveaway Groups' functions. They're probably also what's breaking the Groups sync by the sounds of that error message.

There's a 3 year old closed github issue that sounds somewhat similar to what we're dealing with.
Content Loader: fix group avatar URL #1498

One hack that I tried is to delete the <xx> prefix in the backup json file for groups that use the second URL format. This made those groups Stickyable but it didn't fix Content Loader or Groups sync.

2 months ago*
Permalink

Comment has been collapsed.

congrats PoeticKatana! you qualify as an πŸ‘‡πŸΆ now, welcome to the secret kennel! πŸ’™

2 months ago
Permalink

Comment has been collapsed.

To me it all looks like some secret language, does this mean that it won't be fixed unless rafaelgomesxyz decides to fix it?

Because I sure don't have the brain power to fix it

2 months ago
Permalink

Comment has been collapsed.

It might get fixed without rafaelgomesxyz's involvement if all the groups somehow go back to using the first avatar URL format. I don't know if that's something that SG can control or if it's a problem on Steam's end.

Sadly, the only workaround I see for us as users is to disable syncing and maintain the groups data manually by creating our own json file which is a tedious and error prone process that has to be done every time you join/leave a group. Maybe someone can write a script to do it?

All of that still won't fix the Content Loader issue, but at least it'll make the groups stickyable and Group Highlighter will color the groups correctly.

2 months ago
Permalink

Comment has been collapsed.

It is ancient egyptian hieroglyphics πŸ˜‰, it can be fixed but the problem is only rafaelgomesxyz can push the extention to the store. So your options are use corrected javascript version or load unpacked corrected extention which requires switching on dev mode in the browser.

1 month ago*
Permalink

Comment has been collapsed.

I use the Chrome extension.
The link leads to a "403 Forbidden" page.

1 month ago
Permalink

Comment has been collapsed.

Odd try now i changed file host to mediafire

1 month ago
Permalink

Comment has been collapsed.

429 Too Many Requests. It looks like you've sent too many requests recently. Please wait a few moments and then try again.
(β•―Β°β–‘Β°οΌ‰β•―οΈ΅ ┻━┻

When I use version 8.9.1

1 month ago
Permalink

Comment has been collapsed.

yeah up the limits in setting 9.2

1 month ago
Permalink

Comment has been collapsed.

To what value?
Please keep in mind I'm a total noob at this...

1 month ago
Permalink

Comment has been collapsed.

adding a full second on each worked for me, still testing if it can be lower.

On the minute limits these pushed me to 114 of the 120 SG limit per minute

  1. 0.75
  2. 1.25
  3. 1.5
1 month ago*
Permalink

Comment has been collapsed.

adding a full second on each worked for me

Yay! I now have working "sticky groups" again... Thanks :)

1 month ago
Permalink

Comment has been collapsed.

View attached image.
1 month ago
Permalink

Comment has been collapsed.

I'm going to try your method by deleting the problematic prefixes. In the backup file, is there an easy way to know which ones are problematic ? Or will it be trying the second url format for every groups i have ?

1 month ago
Permalink

Comment has been collapsed.

No way to tell from the backup file itself. The only way I could tell was by going to the group's SG page and checking the URL of the avatar image. I checked a couple of my groups just now and found that all of the them are using format #2, so either they're all broken now, or my theory is incorrect.

In any case, removing the prefixes only helped me make those group eligible to be stickied, but it didn't solve the much more urgent problem with Content Loader and Groups sync not working.

I've decided to turn Content Loader->Groups off for now until rafaelgomesxyz fixes the problem. It was placing a huge burden on my CPU and GPU anyway (consuming multiple GBs of RAM). I don't know if that's due to the bug or if it's an inherent problem with that feature.

1 month ago
Permalink

Comment has been collapsed.

I'll try by removing them all then.

In case someone wants to do it too, here is the replace regexp :
avatar":"[a-z0-9]{2}/ => avatar":"

1 month ago
Permalink

Comment has been collapsed.

And it worked ! My stickied groups are back. I always wondered why some didn't have the sticky icon, that was probably because of this url.

Thanks !

1 month ago
Permalink

Comment has been collapsed.

Having same issue, stuck on "Syncing your Steam groups".

These are both enabled, and API key is there.
limitSteamStore
useCustomAdaReqLim

2 months ago
Permalink

Comment has been collapsed.

Same problem here, it looks like it randomly stopped working for now.

1 month ago
Permalink

Comment has been collapsed.

Am I the only one having problems with groups not being displayed anymore under the giveaways?

I have 2.6.3 turned on, 2.6.3.1 turned off (so I can see all groups) en 3.5 turned on as well.

I didn't change any settings for many months when this suddenly stopped working.

Thanks!

2 months ago
Permalink

Comment has been collapsed.

Yeah, groups are busted right now. I think something changed recently in the way Steam/SG store certain groups' avatar images and ESGST is having trouble finding them at the expected URL.

If any of the groups in a GA happen to have "weird" image URLs, Content Loader (2.6.3) will not display anything under that GA.

I don't know of a workaround. It's pretty annoying.

2 months ago*
Permalink

Comment has been collapsed.

Thanks. I guess I will just be patient. :)

2 months ago
Permalink

Comment has been collapsed.

Yeah, same problem. And while syncing groups works for me and ESGST actually does know in what groups I'm member, it still fails to display this information for some selected groups while it works for others.

2 months ago
Permalink

Comment has been collapsed.

Yeah, I have this issue too. Groups aren't displaying below giveaways. Also, some large groups never finish rolling up their stats in the group view, so I have no idea what my ratio there happens to be. Aargh. That's what I get for becoming so dependant upon this excellent tool. :D

1 month ago
Permalink

Comment has been collapsed.

Might be a duplicate report but I'm unable to sync my steam groups to ESGST. I'm only in ~100 groups but it has never allowed me to sync, it just loads forever. I've tried the two rate limit options in case too many requests was causing the issue but neither fixed my issue.

2 months ago
Permalink

Comment has been collapsed.

I have the same problem currently. I can sync my wishlisted games in a few seconds, but groups never works.

1 month ago
Permalink

Comment has been collapsed.

Maybe I'm dumb, but I thought this plugin had an option to display HLTB and user playtimes on the won page of user profiles...
I can't find it...

Having a searchable index somewhere would be great.

Or was it another script that did this?

2 months ago
Permalink

Comment has been collapsed.

best place to hide something is in plain sight ^^
just below the toolbar is a dynamic searchbar, results are in bold
https://www.steamgifts.com/account/settings/profile?esgst=settings&id=gc_hltb

2 months ago*
Permalink

Comment has been collapsed.

Yeah, when I search, that doesn't seem to work when items are collapsed - and items weren't expanding when clicking Expand All.
(I have almost all of the options turned off by default).
Anyway, from that search link you provided I can now see it's option 9.2.15. Thanks :)

2 months ago
Permalink

Comment has been collapsed.

Why am I getting error when trying "create multiple giveaways"? I click create and it becomes red, saying "Invalid timezone offset". Please advise.

1 month ago
Permalink

Comment has been collapsed.

normally, that's SG telling you it starts before current time and/or ends in < 1 hour or > 30 days, rather than being an ESGST issue

can prevent via template (aka form filler) with every detail desired, except game and key, but can preselect if key/gift
https://www.steamgifts.com/account/settings/profile?esgst=settings&id=gts
create at the bottom of creation page, button to select appears on top left and looks like the bookmarker
can store fixed or dynamic times, relative to current time, using the settings at bottom
templates only store what's filled in at the time they're created, but can overwrite to save changes
I use them for privates, WLs, groups, regions, events, etc., including descriptions ie [NEXT] for trains

remember, you can add multiple keys on separate lines to make a multicopy giveaway, each key still uses a slot

hope at least something in that wall of text is helpful :)

1 month ago*
Permalink

Comment has been collapsed.

Will try next time. Thanks for the wall :)

1 month ago
Permalink

Comment has been collapsed.

still same error no matter what time i try.. now or 3h later to start

1 month ago
Permalink

Comment has been collapsed.

no idea what setting is incorrect or you're possibly doing wrong then πŸ€·πŸΌβ€β™‚οΈ
you didn't mention how long set to end after start
maybe current location is not the region listed in SG profile
maybe disable ESGST to eliminate it as the cause, then one by one any other scripts/addons, as could be a conflict
and I do mean ALL scripts/addons, even if you think they couldn't possibly apply
anything at all changed/updated since your last working gib, would be the most likely culprit

1 month ago
Permalink

Comment has been collapsed.

Its my first time trying with create multiple giveaways..
I fill all info, import giveaways, start time - end time all good. Click create and it fails with that error.
Normally, I can create with no problem 1 by 1.
How will I create multiple if I disable ESGST?

1 month ago
Permalink

Comment has been collapsed.

aha! I see, devil is in the details. I've never used the import/export buttons, so not qualified to help you
does sound like a bug to me too, now
I use +Add with Templates and the Generate button pops a formatting guide for doing so

1 month ago*
Permalink

Comment has been collapsed.

The Chrome extension v8.9.0 stopped working for me today so I migrated to the Tampermonkey script v8.9.1.

After transferring my settings json (from 2 years ago, because I couldn't access the Chrome extension anymore) there seem to be some problems.

First one I found is the advanced filters don't show up.
The giveaways are filtered, but I can't edit the filter (I saved over the DefaultGroups filter)

https://imgur.com/bMbliHg

Is there a way to reset all filters to the default ones?

1 month ago
Permalink

Comment has been collapsed.

Most features (that hadn't already stopped working) stopped working within the last day for me, too, though I can still access my configuration. The author hasn't been on-line at all for 8 months according to his SG profile. I hope he's okay! If he is okay, he may have lost interest in SG and abandoned ESGST. ☹

Edit: He's been active on GitHub within the last month. At least that suggests he's okay... but it also suggests that he may have lost interest in SG and ESGST.

1 month ago*
Permalink

Comment has been collapsed.

For me, I've noticed today that games that are categorized as 'Learning' (or 'Limited') are getting updated and decategorizing themselves, so now my filter on those games does not work anymore.

1 month ago
Permalink

Comment has been collapsed.

For me, Reduced CV games and No CV games stopped syncing since three days ago. "Failed to Sync XYZ".

1 month ago
Permalink

Comment has been collapsed.

Hey all, it's been a really long time since I last logged in here (I have 66 unread messages lol).

I've just been busy with work, so I haven't had time to work on ESGST. Still, I'd like to at least fix critical bugs that prevent the extension from working if I can find some time. I'll try to take some time to go through GitHub issues this weekend and see if there's anything that I can quickly fix - no promises.

I just fixed the ESGST server. For some reason, the AWS instance that holds the server was unreachable, but I rebooted it and it seems to be back: https://esgst.rafaelgomes.xyz/api/info/timestamps

Hope everyone's doing great! I miss my SG days. :(

1 month ago
Permalink

Comment has been collapsed.

Welcome back! πŸ˜„ As you can see - you've been missed. lol

1 month ago
Permalink

Comment has been collapsed.

Welcome back it was starting to get crazy in here 😝,

1 month ago*
Permalink

Comment has been collapsed.

I'm not sure what changes you did, but I added a fix in the original issue that I made myself in regards to that.

1 month ago
Permalink

Comment has been collapsed.

roger

1 month ago
Permalink

Comment has been collapsed.

Welcome back and thanks for not forgetting about us! πŸ˜ƒ

I'm hoping the fix for issue 1732 is relatively simple. Having accurate Steam ratings again would be a blessing.

1 month ago
Permalink

Comment has been collapsed.

Added fix in the repo for rafael to pull if he's interested.

1 month ago
Permalink

Comment has been collapsed.

Aloha! πŸ₯³

1 month ago
Permalink

Comment has been collapsed.

Hello !

A few things that became weird these last weeks for me :

  • can't sync groups (reported by someone else above) => maybe the 3 next points are a consequence of this
  • i have had Stickied Giveaway Groups 3.43 activated for a long time, and it worked, until a few weeks ago, when the sticky icon disappeared from some groups, then nearly all of them (i have only 2 remaining, i don't know why those)
  • 2.6.3, loading GAs groups while hovering on the groups icon only works in the bookmarked GAs page (but i have it everywhere in my options)
  • i can't find the option, but i have checked the one where the groups appear in the GA in lists, but only a handful of groups do that now.
  • Giveaways created and won pages consume a looot of resources and make freezes. New GAs page a little less but still a lot. Other pages are ok. I usually have options on "Everywhere", how come there is a difference ? Last time i had performance problems, i reinstalled Chrome completely (well, it was not even a choice as Chrome simply disappeared somehow), and all went well after that, for some times until now. Is there a less drastic method of refreshing all this without installing everything again ?

Thanks again for this extension, despite all that, it's great !

1 month ago
Permalink

Comment has been collapsed.

I'm also experiencing a lot of performance problems on the giveaways created and won page. It definitely seems to get worse the longer I use ESGST. It's also pronounced on group giveaway pages if I have Endless Scrolling enabled and use a restrictive filter. I think Endless Scrolling keeps loading more pages until a set # is displayed.

The easiest way to alleviate the resource problems on the created/won pages is to disable Created/Entered/Won Giveaway Details (3.5) which is obviously not ideal, since you lose a lot of useful information. A less drastic option is to disable Content Loader (2.6) on those pages and to disable things that generate requests to Steam, for example Games Rating (8.2.26)

1 month ago
Permalink

Comment has been collapsed.

hi, i have a new laptop and set up ESGST add-on again.
before in discussions i had those symbols like for viewing attached images or the giveaway extractor on the left side of the bar with the page navigation. now its on the right.
could someone tell me where i went wrong and how i can get them to be on the left again?
thank you

also syncing data seems to take awefully long... is this normal?
Edit: was only groups that took that long or not at all as others have reported

1 month ago*
Permalink

Comment has been collapsed.

1 month ago
Permalink

Comment has been collapsed.

not sure where i can do that

1 month ago
Permalink

Comment has been collapsed.

refresh a discussion page in a separate tab as you go, which has all the relevant items
ensure this is disabled https://www.steamgifts.com/account/settings/profile?esgst=settings&id=removeSidebarInFeaturePages
expand [+] the 10. Elemental Ordering group (11. if ST enabled)
scroll down to the Left (and Right) Main Page Heading Buttons subgroups
press the reset buttons for both, press green Save Changes button up top and see if that fixes
if not, drag & drop the tags within these two subgroups into preferred order, first (top left) position is leftmost on the bar
remember to Save Changes, before every refresh

1 month ago*
Permalink

Comment has been collapsed.

hey, it worked
resetting helped.
Thank you :)

1 month ago
Permalink

Comment has been collapsed.

Is anyone able to use the tagging function of the multi-manager? I've never been able to. If I try to tag games/users using this method, it just runs forever and makes no progress at all.

1 month ago
Permalink

Comment has been collapsed.

No it has an error Uncaught (in promise) ReferenceError: sortArray is not defined at UsersUserTags.tags_openMmPopup

1 month ago
Permalink

Comment has been collapsed.

Synced groups, but they are still not showing beneath the ga's.

1 month ago
Permalink

Comment has been collapsed.

How long did it take to sync your groups ?

1 month ago
Permalink

Comment has been collapsed.

Seconds.
I changed the timing as per a few comments in the thread.

1 month ago
Permalink

Comment has been collapsed.

It would only be seconds if you had very few groups to check, max SG allows is a about 50 ish per minute. Also some things are broken atm related to groups such as displaying them beneath giveaways, see PoeticKatana's post .

1 month ago
Permalink

Comment has been collapsed.

So maybe they aren't synced, bc I have a lot more than 50 groups ┐(゚~゚)β”Œ

1 month ago
Permalink

Comment has been collapsed.

It has synced if it says it synced. First it checks if you have the groups saved and if you have it does not need to check the group page. If you have added any groups since last sync then it will check the group page and list any new groups so you can see what was added.

TL;DR little new data = fast sync, lots of new data = longer sync with limit capped at 50 ish per min.

1 month ago
Permalink

Comment has been collapsed.

I have actually purged a bunch of groups, so maybe the "no new data" is the reason for the "fast sync"

1 month ago
Permalink

Comment has been collapsed.

Can't select permissions of my choice. When I save it and reload the page all permissions are checked.

1 month ago
Permalink

Comment has been collapsed.

flushing browser cache may fix 🀞

1 month ago
Permalink

Comment has been collapsed.

didn't work

1 month ago
Permalink

Comment has been collapsed.

unclick <all_urls>, save, reload, then select others

1 month ago
Permalink

Comment has been collapsed.

That worked thx!

1 month ago
Permalink

Comment has been collapsed.

Beautiful script. Thank you for making this!

1 month ago
Permalink

Comment has been collapsed.

Content Loader->Giveaway Entries hasn't been working for me the last few days. I just get an empty popout.
Anyone else have the same problem?

View attached image.
4 weeks ago
Permalink

Comment has been collapsed.

Everything Content Loader is related to the avatar URL problem.

4 weeks ago
Permalink

Comment has been collapsed.

Can i delete all of the game without delete one by one? if yes how?

plus seems i can't sync my group list since some weeks now, do you know why?

3 weeks ago
Permalink

Comment has been collapsed.

Sign in through Steam to add a comment.