Hi!

My Windows 10 is turning off my usb receiver. It happens when I am away from computer for a long time, and I've to re-join trough the windows user main screen (I don't know if I'm explaining it well, sorry).

When my usb wifi receiver is working fine, the wifi icon appears in the taskbar near to the clock, as shown in this image: https://i.imgur.com/baBQr8a.png

However, when I return to my computer after some time, the wifi connection is gone and I have the ethernet icon in my taskbar: https://i.imgur.com/B6jFmrY.png

This is not a big problem, I know. I just need to unplug and plug again my wifi usb. But this is turning annoying, and I'm sure it has an easy solution I don't know.

Any clues, guys? Thank you in advance and, as usual, sorry if my english is not good enough.

1 month ago

Comment has been collapsed.

1 month ago
Permalink

Comment has been collapsed.

+1

1 month ago
Permalink

Comment has been collapsed.

Done! I hope this work. Thanks, man!

1 month ago
Permalink

Comment has been collapsed.

Probably that, yeah. Alternatively, your wifi stick is old, and starting to fail (this is unlikely if, while you're using it, you have no problems).

1 month ago
Permalink

Comment has been collapsed.

Ooops, it doesn't fix my problem :(

1 month ago
Permalink

Comment has been collapsed.

I had the same problem. I had a network card connected inside the computer case (literally, I managed to make USB port inside my case) and sometimes my computer was losing connection. It turned out, that my case is so thick that it did not let the connections through and after connecting the network card outside the case the problem was solved. I also bought Xiaomi Mi Wi-Fi Repeater 2 for better wifi range and it really works. I hope that will help you somehow.

1 month ago
Permalink

Comment has been collapsed.

Thanks! I'm almost sure this is not a wifi range problem, but a Windows configuration problem. Anyway, thanks for the tip!

1 month ago
Permalink

Comment has been collapsed.

Had similar issues, one time it was the receiver just being broken, i feel it also doesn't like the usb 3 ports much, just try sticking it in other ports front or back. I probably made a topic about it, but trust me the answer can be not so easy

Is it a laptop or pc?

1 month ago
Permalink

Comment has been collapsed.

It's a PC. I've tried different usb ports, and the wifi usb is a little bit old, so maybe is I can't fix it, I'll buy a new one.
Thanks!

1 month ago
Permalink

Comment has been collapsed.

Atleast they aren't expensive, if you want to go the aliexpres route you could even get this which even goes to 600mbps and you can choose between 2.4ghz or 5ghz https://nl.aliexpress.com/item/32920514630.html?spm
A colleague used it and praised it and i might gonna try it too.
Although tp links only cost a few tenners for 300mbps (maybe a bit more reliable).

How many mbps is the stick? Did the provider up your speeds recently? here they like to keep increasing the speeds under the name of "service" but also means paying more each year but then you get certain speeds you also gonna need a new router, and a new isp modem.

One other thing you can do is go to configuration screen > devices management > networkadapters> find your wifi thing and right click, go to energy management and thick off "the pc may disable this device to save energy" this most likely will not work (as it didn't for me) (and dunno if it's similar to the first post) but can't hurt either.

1 month ago*
Permalink

Comment has been collapsed.

Laptops are PCs too, it's laptop or desktop. :)

1 month ago
Permalink

Comment has been collapsed.

Alternative: are you certain it’s a Windows issue and not a hardware or network issue?

1 month ago
Permalink

Comment has been collapsed.

Not really. As I said to Lugum (previous comment) the usb wifi is old. I'll give it a try and, if necessary, I'll buy a new one. Thanks!

1 month ago
Permalink

Comment has been collapsed.

I'm guessing Windows is powering down the USB port while you're away from your PC for some time. Check for a setting under power management or in device manager to prevent this.

1 month ago
Permalink

Comment has been collapsed.

Real fix would be to just use the ethernet for 100x better reliability.

1 month ago
Permalink

Comment has been collapsed.

Sign in through Steam to add a comment.