Here suppose these icon will appear but recently iy no longer appear in 1 of my pc.
[img]https://i.imgur.com/WXHEMlL.png[/img]
[img]https://i.imgur.com/FvQEDdy.png[/img]

I clear all site data, clear all cookies, site content but none of that can it give me back the normal view with icon.
Anyone know what is the problem?

1 month ago

Comment has been collapsed.

You use scripts?

Tried other browsers, what browser does it not work?

1 month ago
Permalink

Comment has been collapsed.

Deleted

This comment was deleted 1 month ago.

1 month ago
Permalink

Comment has been collapsed.

It happens sometimes when PC's are getting old or need a cleanup (from viruses, cookies, etc...).

Not talking exclusively about SG: icons dissapearing even in windows ui.

That's my experience of it anyway.

But surely, If you are using scripts (looks like it from the pics) wont help having a "normal version of the website".

1 month ago
Permalink

Comment has been collapsed.

My guess is the ESGST addon for your browser got removed or disabled

1 month ago
Permalink

Comment has been collapsed.

+1 both are ESGST options

1 month ago
Permalink

Comment has been collapsed.

but I disable ESGST long time ago. That time don't have this problem.
Now I enable it, still same.
Do you know how to set it?

1 month ago
Permalink

Comment has been collapsed.

You can try to sync your account and log out and log in to SG.

1 month ago
Permalink

Comment has been collapsed.

Both of my pc using it for long time already. Recently no install nor adding anything.
So many year no problem just last week until now 1 of my pc losing this icon while another pc still ok.
At start I though is steamgift website problem then after wait a few day and the problem still at there, then I start clean all the firefox cache, site data, cookies, still fail. Then I though is some extension-add on in firefox so I disable all then try again still same problem.

1 month ago
Permalink

Comment has been collapsed.

Try doing a search for firefox font awesome icons missing and look through some of the results. I have no idea what the issue is, but other people have had the same problem in the past, so maybe those threads will help you find a solution.

1 month ago
Permalink

Comment has been collapsed.

ok, I will try it.
Thanks

1 month ago
Permalink

Comment has been collapsed.

I think I found out the problem. I think it related to dns.
I change the dns to 8.8.8.8 and 8.8.4.4 and now all icon show up.
Those old dns which is 1.9.1.9 and 202.188.18.188 I had use for many year without problem. Don't know why now it become problem.
This dns also solve my problem in chrome that cannot display steam website image properly. Don't know why it only happen to chrome while firefox can display steam website properly with old dns.

conclusion
Old dns, my firefox can display steam website properly without problem but steamgift website got display problem(recently only).
Chrome cannot display properly on steam website.

New dns all can display properly.

1 month ago*
Permalink

Comment has been collapsed.

Sign in through Steam to add a comment.