hello folks,
so i had this problem for a very long time now
when playing a game (steam) and being afk for a while, the pc (Laptop) goes to sleep, all black screen etc.
after returning the sound in the game is gone.
other sounds like videos and the sound test function still works. but no sound in the game.
the only thing that helps is quitting and restarting the game.

i always thought this is due to my laptop being old and buggy
but now i got a new laptop just yesterday, and the same problem persists.

btw... im using a Sony TV as second monitor through which the sound is usually played through.
i also tried changing it to laptop but it doesnt help

thanks for reading

EDIT:
im not sure if this is happening with all games but it definitly happens with quite a few games.
im currently experiencing this with "The Last Tinker™: City of Colors"
you cant save manually inbetween and the save spots are very far apart so i have to let it keep running while doing something else

thanks for the suggestions up until now :)

1 week ago*

Comment has been collapsed.

Did you try without secondary monitor plugged in ?

If this is only a sound routing issue you could try this app https://softradar.com/audio-router/

1 week ago
Permalink

Comment has been collapsed.

i havent tried that
i might try to unplug and plug it back in next time it happens, but i wouldnt want to go without it as its set as no1 monitor and im playing the games on it.

also im not really sure why this would be cause by any hardware... other sounds are still playing through both the TV and the laptop... just not the game... so i'd rather think that it is caused by the games themselves?

im not really keen on installing stuff now... especially on the new laptop
could you explain what it does? ....to a noob? lol

1 week ago
Permalink

Comment has been collapsed.

Set the sleep mode to a higher needed time till it starts or disable the afk mode of the laptop.

1 week ago
Permalink

Comment has been collapsed.

increasing time to maybe something really high as i really dont know at times how long i will be gone... you know.. with a baby and stuff...
was actually thinking about disabling it altogether though i'd like to save that little energy :P

1 week ago
Permalink

Comment has been collapsed.

i've set it to 1h now
lets see how long i can deal with that :P

1 week ago
Permalink

Comment has been collapsed.

I am sure you will like it this way much more and the baby stuff, mostly, don't need 1h (if you not sleep in with the baby^^ -i was known for that with my son [but hey...he sleeped... too^^-)

1 week ago
Permalink

Comment has been collapsed.

lol its mostly the feeding
preparing the food, feeding may take a while if she doesnt want to, then cleaning and washing everthing afterwards ... and well... playing with her :)

1 week ago
Permalink

Comment has been collapsed.

I am having a similar problem, but if i put it manually to sleep again and wake it up, the sound comes back :D Not a real solution, but its something... 😅

1 week ago
Permalink

Comment has been collapsed.

i often have to go spontaneously as i have a baby to take care of... but that might be something i could do sometimes... though i wouldnt know how XD

1 week ago
Permalink

Comment has been collapsed.

though i wouldnt know how XD

Sleep mode can be toggled through your power icon in your start menu [ie, alongside Shut Down and Restart].

1 week ago
Permalink

Comment has been collapsed.

restart audio service - additionally, changing this service's setting to always on may even permafix

1 week ago*
Permalink

Comment has been collapsed.

i might try that next time though i dont get that specific error ... there is no message at all.
just no sound from the game

1 week ago
Permalink

Comment has been collapsed.

https://www.google.com/search?q=laptop+no+sound+after+sleep+mode&oq=laptop+no+sound+after+sleep+mode&aqs=edge..69i57.5718j0j1&sourceid=chrome&ie=UTF-8

Seems to be a common issue, some suggestions, update your bios, not have the latest nvidia drivers.

1 week ago
Permalink

Comment has been collapsed.

well... its not like there is no sound at all, just the game sound that is gone. i tried googling this before posting here
also the laptop is brand new and my husband installed all the drivers and stuff... should be all the newest i guess.
oh and it has win11 now but my old laptop with the same problem had win10.

1 week ago
Permalink

Comment has been collapsed.

after returning [from Sleep] the sound in the game is gone.

That should be tied into the game(s) in question utilizing specific outdated sound software, or utilizing their sound software in a clumsy manner. *As I recall* the process: PCs won't shut down if there's an active audio context connection; Depending on how a game and its associated sound software is configured, this can result in a game being set up to effectively lock out sleep mode (due to the resources remaining in use), being set to load in and out of sleep mode without issue, or being set to load into sleep mode but then fail to reattach to the associated hardware resources once returning from Sleep Mode. In that last case, given how the context'd need to be reeactivated, and that a context is enabled specific to a given game, this results in the game in question needing to be reloaded to reactivate the associated sound. [If I'm misrecollecting anything, and anyone happens to notice, do please note corrections.]

[ Simple version: Some games just aren't configured to operate well with Sleep mode, due to having their audio connections being configured in a way that will either block Sleep mode out or not reenable sound after returning from Sleep mode. ]

Regardless of the actual underlying functioning, I've personally also had that issue with specific games, with the effect occuring regardless of the device and software used, and with ready feedback from other online users indicating that it was also specific to that game for them as well. I wasn't ever able to find a fix for any of the affected games, ultimately just opting to disable sleep mode instead on my gaming-oriented computers. ( That said, if any of the other users here do end up giving you a fix that does manage to work, do give me a poke and let me know. :) )

(Note, the games with problems that are in question are consistent in their having sound loss per load from Sleep mode, with the issue also being consistent across devices. If you're having any inconsistencies, then you may be facing a different issue, of which several other posts seem to have already given possible approaches for addressing.)

1 week ago*
Permalink

Comment has been collapsed.

yeah thats what i started to think as well, that its a game specific issue
will poke if i found a fix :)

1 week ago
Permalink

Comment has been collapsed.

This probably happens because the HDMI connection drops when the laptop goes to sleep and the HDMI audio driver disables itself.
Either the game is still connected to that specific audio connection or the the connection that was the default one when the HDMI connection dropped is selected for the game.

possible solutions:

  • switch the current audio to your speakers, then switch it back to HDMI (Sound Settings -> Output -> change the selected device in the drop down)
  • set the HDMI device as the default one in Control Panel -> Hardware and Sound -> Manage Audio Devices and set the HDMI audio as the default one
  • try finding newer drivers for the HDMI audio interface as it could be a bug

also it could be a bug related to that specific game, try to run a different game and experiment with that

unfortunately that's all that I coud find via sleuthing the internet, hope it helps you.

1 week ago
Permalink

Comment has been collapsed.

+1 Maybe this is the right answer.

It also appears to occur when the HDMI of some monitors and graphics boards do not support the copyright protection feature.

1 week ago
Permalink

Comment has been collapsed.

  • tried switching, didnt work
  • TV is default or set to no1
  • new laptop with all new drivers

i started to think that its game specific like sooth above said

1 week ago
Permalink

Comment has been collapsed.

I used to face similar issues when I had a laptop. I think for some games I was able to fix it by toggling the audio output device, iirc, while for other I had to restart the game. What DeS3InY said seems to be really helpful too.

Another tip is to play an video on loop in the background while gaming or disable sleep (you can easily toggle between power profiles if you want sleep while not gaming). This is similar to the suggestion above about increasing the time before system goes to sleep, however, this way you can prevent the system from going to sleep only when gaming. So, this might be the solution to "save that little energy" issue.

1 week ago
Permalink

Comment has been collapsed.

would you tell me about those profiles? how to set them up and toggle

1 week ago
Permalink

Comment has been collapsed.

thank you
i'll see to it when i had to time to focus on that.

1 week ago
Permalink

Comment has been collapsed.

Np :)

1 week ago
Permalink

Comment has been collapsed.

Unity-based games are shocking for audio issues. If you've had no luck with the other suggestions, I'd see if you can track down whether it's just certain games that have this issue.

1 week ago
Permalink

Comment has been collapsed.

1 week ago
Permalink

Comment has been collapsed.

just started the game and i havent seen any unity in the starting screens.
but that would definitly be interesting to know if there is a connection.

i know i had this problem with a few games, though i cant remember now. i ts not all games, as well as i often didnt let it go to sleep and rather just quit the game.

i might start keeping track of that. though now that ive increased the time till it black outs this might occur more seldom

1 week ago
Permalink

Comment has been collapsed.

What other games did you have previous sound problems with (the ones you can remember)? The Last Tinker is a Unity game https://en.wikipedia.org/wiki/The_Last_Tinker:_City_of_Colors and https://steamcommunity.com/app/260160/discussions/0/527273452880118739/

1 week ago*
Permalink

Comment has been collapsed.

i believe i remember hollow knight doing this... though not sure.
this was usually not much of a problem as i would simply save/find nearest saving spot and quit, either before leaving it alone or when it happened. no problem
its just with this game the last tinker the saving spots (finishing and leaving an area) are quite far apart, and i wouldnt know how much until then. which is why with this game its its really annoying and i would have liked a solution for it.

1 week ago
Permalink

Comment has been collapsed.

Sign in through Steam to add a comment.