Lately Steam has been experiencing quite a bit of issues with how it shows or loads usual stuff in it's client or pages. Wishlist, reviews and some other pages among them.

Now there was black box greeting instead of chat and was already wondering did they invent a time machine and put it back to 90's DOS. Seems like quite a few people have reported having this issue so far at Steam discussion. Possible fix is to get friend sent a message to you.

View attached image.
1 month ago

Comment has been collapsed.

Had issues in late few months?

View Results
Yes
No
Features.. they are features
Browser version doesn't have these issues

Not your exact issue, but I've suffered from a black library page countless times. Can't see any games. No fix other than to quit and restart.
All of these problems are with the new UI. The old version worked perfectly.
I even tried to block steam client updating to preserve the old one, but this cost me the steamville badge since the multiplayer / remote play type task broke without it. Support wasn't able to help in time, so lost forever.

1 month ago
Permalink

Comment has been collapsed.

Yep, the blank library is the one I encounter the most too.

1 month ago
Permalink

Comment has been collapsed.

Same here. Already minimized all shelves/categories, but still happens.

1 month ago
Permalink

Comment has been collapsed.

Haven't seen black library yet, but think it actually did fail to load at certain point. EpicKK did point about being in beta program that did actually apply in back in the day. Removing access to that did fix currently mentioned issue and slow game startup that was annoying, as any tiny fast load up game could take quite long time to start.

Actually prefer new UI personally, but indeed if it comes only with issues then it would be better to have option to use old one. Guess they are fiddling around good amount considering how often did have updates in beta and how often these issues kept popping up. Well now will see if there's more to come since discontinued beta in client.

Shame that stuff was lost forever and they didn't help to recover it, but guess they've been bit picky about it in several ways. :l

1 month ago
Permalink

Comment has been collapsed.

I did write support before the event ended, but support answered after only to tell me they could have helped during the event.....

1 month ago
Permalink

Comment has been collapsed.

^^ i miss the old library

1 month ago
Permalink

Comment has been collapsed.

steam is the new black

View attached image.
1 month ago*
Permalink

Comment has been collapsed.

Actually i only encounter those issues ,when im participating in the steam beta ,without beta or steam sale i usually dont have any trouble .

1 month ago
Permalink

Comment has been collapsed.

Happy cake day :o)

Du im discord inaktiver :-P

1 month ago
Permalink

Comment has been collapsed.

Danke ,war aber allgemein bissl inaktiver .

1 month ago
Permalink

Comment has been collapsed.

Actually now that you notified about it, was also in beta program. Did put it off and tested around a bit and seems like that did fix issue for very slow game startup and chat didn't come up as black window anymore in games either. Thanks for pointing it out, game startup was quite annoying and did fiddle around it a bit as there weren't any hardware based issues from what did check out. :) Outer World did show on wl spot 2, but afterwards it was gone again so guess that's some other issue besides beta.

Happy cakes as well EpicKK! :3

1 month ago
Permalink

Comment has been collapsed.

View attached image.
1 month ago
Permalink

Comment has been collapsed.

Closed 1 month ago by heilurmes.