Only on this site, so I don't think the problem exists on my end.

3 months ago

Comment has been collapsed.

Same, but only on my phone.

3 months ago
Permalink

Comment has been collapsed.

Same here! ☚ī¸

3 months ago
Permalink

Comment has been collapsed.

I can't help, but i'll add onto it by saying i have this problem as well, only on my phone though.

3 months ago
Permalink

Comment has been collapsed.

Yup, started noticing it roughly a day ago. It happens on every refresh or new page opening.
This is not on phone but on Firefox on PC.

3 months ago
Permalink

Comment has been collapsed.

Yeah, it's this website's ad-service/tracker. I removed the website from my adblocker's whitelist on my PC and phone and the issue is gone on both of them.

3 months ago
Permalink

Comment has been collapsed.

The site doesn't seem to remember my settings and keeps popping up in the giveaways section(s) but in the forums it works fine.

3 months ago
Permalink

Comment has been collapsed.

Exact same problem.

3 months ago
Permalink

Comment has been collapsed.

I'm afraid I don't understand, what is this "privacy window" you are referring to? Can you post a screenshot?

3 months ago
Permalink

Comment has been collapsed.

It's that cookie "window" that some ppl just accept all and forget.
Actually is a page div, not really a window.

3 months ago
Permalink

Comment has been collapsed.

oh, I've been logged on the site for forever, so I don't remember seeing any cookie consent overlays.

I tried to open SG in a private window (with adblocking disabled) but I still don't see it... I'm on Firefox desktop btw.

maybe it's a regional thing (GDPR and EU?)

3 months ago
Permalink

Comment has been collapsed.

Probably will appear if you clean the browser cache. I have Firefox too.

Edit: maybe an addblock extension will keep it away.

3 months ago
Permalink

Comment has been collapsed.

Yep it's EU and it's terrible.

3 months ago
Permalink

Comment has been collapsed.

3 months ago
Permalink

Comment has been collapsed.

I see, in that case it appears this is coming from 3rd party ads served on SG (as mentioned in the privacy policy page), and since you are from the EU, they are required to show this cookie consent dialog to use your data to provide "personalized ads"

Personally I've never had this show up for me on SG.. Then again, I use a pretty hardended firefox browser with privacy-oriented settings and extensions

3 months ago*
Permalink

Comment has been collapsed.

+1 (phone + firefox) any other browser ?

3 months ago
Permalink

Comment has been collapsed.

Same on Opera.
I'm in the EU, if relevant (GDPR).

3 months ago
Permalink

Comment has been collapsed.

I'm somewhat suspicious of the enhanced anti-tracking features of those browsers.
Perhaps if we give them the Steamgifts URL in the cookie exception, they would be mature enough to do so.
🤔<Was this correct?

Enhanced Tracking Protection in Firefox for desktop | Firefox Help
https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop
Total Cookie Protection and website breakage FAQ | Firefox Help
https://support.mozilla.org/en-US/kb/total-cookie-protection-and-website-breakage-faq

How do I stay logged into specific websites?
Add an exception at Settings > Privacy & Security > Cookies and Site Data > Manage Exceptions. Make sure you add a website to the exceptions before you login, both http and https versions of the domain. If you want to stay logged into https://www.steamgifts.com enter example.com and click on "Allow": you should then see the two versions listed, and you can go ahead and save the changes.

3 months ago
Permalink

Comment has been collapsed.

I've had the same problem. Just erase the cookies for this website and voila.

3 months ago
Permalink

Comment has been collapsed.

Flawless solution, thanks.

3 months ago
Permalink

Comment has been collapsed.

It's not that easy. It's obviously the site's problem, not the browser's.

3 months ago
Permalink

Comment has been collapsed.

This worked for me also!

3 months ago
Permalink

Comment has been collapsed.

Yes , it worked for me!

3 months ago
Permalink

Comment has been collapsed.

For some reason it's been fixed apparently.

3 months ago
Permalink

Comment has been collapsed.

I have the same problem. Cleared cookies and other data, relogged in and still the same (android + firefox).

3 months ago
Permalink

Comment has been collapsed.

Bump

3 months ago
Permalink

Comment has been collapsed.

Still hasn't been fixed. Clearing cookies seems to get rid of the problem for a few hours at most and then it's back to happening on every site refresh and page change.

3 months ago
Permalink

Comment has been collapsed.

Sign in through Steam to add a comment.